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1. Introdução

QField e Mergin Maps, são duas aplicações baseadas em QGIS, que permitem utilizar projetos QGIS em dispositivos móveis

(smartphone/tablet) diretamente em trabalhos de campo. 

A sua integração com o QGIS Desktop e o PostGIS, possibilita entre outras coisas, a edição de pontos, linhas e polígonos com

recurso a GPS e a utilização de formulários avançados para a recolha de dados alfanuméricos.

 

 

Este documento, apresenta uma sequência de passos que abordam técnicas relacionados com a criação e configuração de

projectos QGIS para uso no QField ou no Mergin Maps, sendo que neste workshop iremos centrar-nos mais no uso do QField.

Para facilitar, foram usadas as seguintes convenções tipográficas:

Referências a menus, ferramentas e teclas de atalhos dos softwares, aparecem a negrito. Ex. menu Project > Project Properties

Referências a pastas ou ficheiros, encontram-se em itálico. Ex. layer freguesias.shp

Os dados a utilizar são criados durante o desenvolvimento do workshop.

1.1 Dúvidas

Para qualquer dúvida, envie mail para João Gaspar ou Nelson Silva

• 

• 
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2. Instalação e Configuração

Visto que ambas as aplicaçãoes são para dispositivos móveis, a sua instalação é feita utilizando as ferramentas de instalação do

sistema operativo do dispositivo. 

Atualmente é possível instalar o QField e o Mergin Maps em dispositivos Android, iOS e Windows. Neste documento, fazemos

referência ao processo de instalação em dispositivos Android através do repositório Google.

Para instalar qualquer uma das aplicações em Android, basta:

1 - Aceder ao Play Store  da Google 

2 - Pesquisar por QField ou Mergin Maps, selecionar a aplicação pretendida e instalar 

3 - Após a instalação, inicie o QField e abra um dos projecto de demonstração

4 - Para adecer às configurações do QField, faça a seguinte:

Clique no botão  

No separador General, altere o aspeto e idioma do QField a gosto

• 

• 
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5 - Explore um pouco os restantes separadores

6 - Por fim, feche a aplicação

Se pretender ter o QField no Windows, poderá efetuar o download do executável no endereço https://qfield.org/get_latest/?

platform=windows.

Dica

2. Instalação e Configuração
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2.1 Plugins QGIS

Para auxiliar no processo de preparação, exportação e importação de um projeto QGIS para o QField ou Mergin Maps, foram

desenvolvidos dois plugins. 

QField Sync - https://docs.qfield.org/get-started/tutorials/get-started-qfs/

Mergin - https://merginmaps.com/docs/manage/plugin-sync-project/

Após iniciar o QGIS, siga os seguintes passos para a instalação de qualquer dos plugins:

1 - Aceda ao menu Plugins > Manage and Install plugins

2 - Pesquise por QField ou Mergin e instale o plugin pretendido

3 - Ambos os plugins, acrescentam uma nova entrada no menu Plugins , uma nova barra de ferramentas e um grupo no painel 

Browser

• 

• 
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3. Criação de Layers e Projeto

Todo o trabalho de preparação e configuração dos layers para utilização na recolha de dados em campo, passa pela criação de

um projeto QGIS. Neste workshop, será criado um projeto com vista à recolha de informação sobre observação da abetarda no

distrito de Évora.

3.1 Criação de BD GeoPackage

O GeoPackage é um formato aberto, que entre muitas caraterísticas, permite armazenar informação num único ficheiro.

1 - No painel Browser, navegue até à opção Home e com o botão do lado direito do rato, crie uma diretoria chamada 

geo_abetarda

2 - Selecione a diretoria criada no passo anterior e novamente com o botão do lado direito, escolha a opção New e depois 

GeoPackage

3 - Após a criação do GeoPackage, este irá aparecer no painel Browser. Com o botão lado direito, escolha a opção Manage e

altere o nome para db_abetarda.gpkg

4 - Selecione o GeoPackage e com o botão do lado direito, escolha agora a opção New table e defina as seguintes caraterísticas:

Table Name – censo_abetarda

Geometry type – Point

CRS – EPSG:3763

New Fields – crie os seguintes atributos

Por fim, clique em OK

4 - Crie uma nova tabela sem geometria com as seguintes caraterísticas:

• 

• 

• 

• 

Name Type

utilizador Text

data_registo Date

concelho Text

freguesia Text

latitude Decimal number

longitude Decimal number

genero Text

idade Text

voo Boolean

deslocacao Text

observacoes Text

foto Text

• 

Nome da tabela Atributos

lista_deslocacao sentido

3. Criação de Layers e Projeto
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5 - Adicione as tabelas criadas ao QGIS

6 - Abra a tabela de atributos lista_deslocacao. Coloque em modo de edição e acrescente os valores apresentados na seguinte

imagem:

7 - Termine a edição, guardando as alterações da tabela

3.2 Criação de Projecto

Visto que a base de funcionamento do QField e do Mergin Maps, é um projeto QGIS, salve o projecto com o nome 

geo_abetarda.qgs

Vamos adicionar mais alguns dados ao projeto, os quais são disponibilizados sob a forma de web services, utilizando os

protocolos WMS e WFS. 

No QGIS, siga os seguintes passos:

1 - No painel Browser, clique com o botão do lado direito sobre a opção WFS / OGC API -Features e escolha New Connection.

Defina as seguintes propriedades:

Name – CAOP DGT

URL – copie e cole o link https://geo2.dgterritorio.gov.pt/geoserver/au/wfs?version=2.0.0

Feche a janela

2 - Repare que agora já aparece o nome da ligação. Abra a ligação e carregue o layer Administrative Units

3 - No painel Layers, ative o layer Administrative Units e através da ferramenta Select Features by Value (tecla de atalho, F3 ),

selecione os limites administrativos do distrito de Évora.

• 

• 

• 

3.2 Criação de Projecto
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4 - Com o botão do lado direito sobre o layer, escolha Export > Save Selected Features As  e salve o ficheiro na pasta criada

anteriormente. Defina o nome como fregs.shp 

5 - Faça uma aproximação ao layer criado e remova o layer WFS

6 - No painel Browser, clique com o botão do lado direito sobre a opção WMS/WMTS e escolha New Connection. Defina as

seguintes propriedades:

Name – Ortos 2018 - DGT

URL – copie e cole o link http://cartografia.dgterritorio.gov.pt/ortos2018/service?service=wmts&request=getcapabilities

Feche a janela

7 - Abra a ligação e carregue o layer Ortos2018-RGB

8 - No painel Layers, crie um grupo  designado por Tabelas Auxiliares e outro como Mapas Base

9 - De acordo com a imagem abaixo, arraste os layers em questão para os respetivos grupos

10 - Salve o projecto

3.3 Configurações do Projecto

Os layers num projecto para recolha de dados em campo, podem ser usados apenas para visualização, consulta/pesquisa de

informação e edição.

1 - Aceda ao menu Project > Properties

2 - Na propriedade General, confirme se a opção Save paths está como Relative

3 - Em Data Sources, efetue as seguintes configurações:

Desligue as opções Searchable para todos os layers, com excepção do layer fregs

Desligue a opção Identifiable para o layer Ortos2018-RGB e fregs

Clique em Apply

• 

• 

• 

• 

• 

• 
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4. Configuração dos Layers

A utilização de dispositivos móveis em trabalho de campo, nem sempre é fácil. Por exemplo, os ecrãs dos dispositivos com o sol

não se vêem bem e com chuva torna-se dificil a sua utilização.

Assim, o desenho do formulário para a recolha dos dados, deve ser o mais simples possível, de forma a facilitar a introdução dos

mesmos a quem vai efetuar o levantamento no terreno.

4.1 Widgets de atributos

O QGIS permite a configuração de widgets para quando se edita ou cria dados, certos atributos possam preenchidos/atualizados

automaticamente ou permitir ao utilizador ter acesso a uma lista de valores aceitáveis para essa coluna.

Para saber quais os widgets atualmente suportados, consulte os respetivos links:

QField - https://docs.qfield.org/how-to/attributes-form

Mergin Maps - https://merginmaps.com/docs/layer/settingup_forms/

1 - Aceda às propriedade do layer censo_abetarda e altere a símbologia a gosto

2 - No separador Attributes form, defina as seguintes configurações para os vários atributos:

3 - Após essa configuração, clique em Apply e feche as propriedades

4 - Coloque o layer observacao_abetarda em edição e verifique o resultado ao tentar adicionar um ponto

5 - Cancele a janela e termine a edição sem guardar as alterações

• 

• 

Coluna Widget Type Filter expression/Constraints Defaults

fid Hidden - -

utilizador Text Edit - @utilizador

data_registo Date/Time - now()

concelho Value Relation Layer fregs -

freguesia Value Relation "concelho" = current_value('concelho') -

latitude Decimal number - y(transform($geometry, 'EPSG:3763', 'EPSG:4326'))

longitude Decimal number - x(transform($geometry, 'EPSG:3763', 'EPSG:4326'))

observacoes Text Edit - -

genero Value Map - Masculino, Feminino

idade Value Map - Jovem, Adulta, Idosa

foto Attachement - -

voo Boolean - -

deslocacao Value Relation Layer lista_deslocacao -

4. Configuração dos Layers
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4.2 Formulário de atributos

Por defeito, o QGIS define um formulário corrido na vertical. No entanto, caso os atributos a preencher em campo sejam muitos,

este tipo de formulário não é prático. Assim, vamos configurar o nosso formulário para pode apresentar os atributos em dois

separadores.

1 - No separador Attributes form, altere a opção Autogenerate para Drag and drop designer

2 - Clique no botão  e crie o primeiro separador com o nome Geral

3 - Repita o processo anterior, acrescente mais um separador com o nome Observações

4 - Por último, acrescente um grupo ao separador Observações, definindo o nome como Sentido Deslocação

4.2 Formulário de atributos
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5 - Seguidamente, de acordo com a imagem abaixo, arraste os atributos para dentro dos respectivos separadores

Com a tecla Ctrl  do teclado, podemos selecionar vários atributos ao mesmo tempo e arrastá-los para o local desejado.

6 - Selecione o grupo Intervenção

7 - Ative a opção Control Visibility by Expression e defina a expressão "voo" in ('t', true, 1)

8 - Termine com Apply

9 - Coloque o layer censo_abetarda em edição e acrescente um ponto. Verifique se todas as configurações dos atributos estão a

funcionar

Dica
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4.3 Definir atributos de pesquisa

Para podermos pesquisar atributos num layer no QField, é necessário que esse layer esteja definido como Searchable nas

propriedades do projecto conforme visto no capitulo anterior. No entanto, é ainda necessário especificar o(s) atributo(s) nas

propriedades do layer no QGIS.

1 - Efetue um duplo clique no layer fregs

2 - Altera a símbologia apenas para mostrar o contorno e cor a gosto

3 - Na propriedade Labels, defina o atributo Des_Simpli como etiqueta/rótulo

4 - Na propriedade Display, selecione o Des_Simpli na opção Display Name

5 - Por fim, clique em Apply e salve o projecto

4.3 Definir atributos de pesquisa
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5. Transferência e Sincronização

Após a configuração do projecto, é hora de o transferir para o dispositivo móvel. Para isso, podemos simplesmente copiar os

dados/pasta para dentro do dispositivo ou então se o projecto vai ser usados por vários utilizadores, utilizar o plugin QFieldSync

para preparar e empacotar os projectos a distribuir pelos vários dispositivos de recolha.

A transferência dos dados, pode ser feita através do cabo de alimentação do dispositivo (usb), ou então, utilizando algum serviço

online, tal como NextCloud, Google Drive, Dropbox, etc.

A alternativa, passa pela utilização das plataformas cloud fornecidas por cada uma das soluções. 

QField Cloud - https://app.qfield.cloud/accounts/signup/

Mergin Maps - https://app.merginmaps.com/register

5.1 Modo Offline

O plugin QFieldSync foi desenvolvido para auxiliar no processo de configuração dos projetos para QField. Para mais informação

acerca do plugin, consulte o site https://qfield.org/docs/synchronise/qfieldsync.html.

Com a instalação do plugin QFieldSync, é criada uma pasta QField que está associada ao utilizador do PC. Em Windows, C://

utilizadores/nelson/QField.

Antes de tudo, é possível configurar as pastas de exportação e importação dos dados. Para isso, basta aceder ao menu Plugins > 

QFieldSync > Preferences .

• 

• 

5. Transferência e Sincronização
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5.1.1 QField Cloud

1 - Aceda ao menu Plugins > QFieldSync > Configure Current Project

2 - Configure as várias opções tal como exemplificado na imagem abaixo

3 - Salve as alterações ao projeto

4 - Seguidamente, aceda ao menu Plugins > QFieldSync > QFieldCloud Projects Overview  e introduza as suas credenciais de acesso à

plataforma QFieldCloud

5.1.1 QField Cloud
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5 - Clique no botão  para criar um novo projeto na plataforma

6 - Aceite a opção Convert currently open project to cloud project  e configuere os detalhes associados ao projeto

7 - Por fim, clique em Create e espere que o projeto seja convertido e carregado para a plataforma QFieldCloud

5.1.2 PC

Se o objetivo é fazer a exportação do projeto para o computador e depois transferi-lo por cabo ou outra solução que não o

QFieldCloud, os passos a seguir são: 

1 - Nas propriedades do projeto, definir as opções necessárias do QField, no separador Cable Export 

2 - Seguidamente basta usar o botão , definir o nome da pasta a criar e proceder à exportação do projeto

3 - Após concluir o projeto, é apresentada uma mensagem ao cimo com o caminho para a pasta criada. Clicando nesse endereço,

o Explorador do Windows é aberto. Em função das opções de exportação, podem existir essencialmente dois ficheiros

geopackage:

data.gpkg - contêm os layers a usar na recolha offline

basemap.gpkg - contêm o mapa base gerado

Estes ficheiros, podem ser abertos fora do QGIS, utilizando para isso numa aplicação como o DB Browser for SQLite.

• 

• 

Info
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4 - Após isso, em dispositivos Android, basta transferir a pasta criada para o dispositivo móvel. Para evitar a importação do

projeto para o QField, pode-se colocar a pasta do projeto logo na directoria Android > Data > ch.opengis.qfield > files > Imported Projects

5 - Para abrir o projeto no QField, deve-se escolher a opção Open local file e ir buscar o projeto existente na pasta Imported

Projects 

6 - Depois disso, é começar a editar geometrias de acordo com as nossas necessidades

7 - Se abrirmos a pasta de dados do projecto no explorador de ficheiros do dispositivo móvel, percebemos que existem dois

ficheiros com as indicações -wal e -shm. Estes ficheiros são usados para guardar as alterações efectuadas nos nossos dados

5.1.2 PC
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Para mais informação sobre estes ficheiros, consulte o site https://www.sqlite.org/tempfiles.html.

5.1.3 Partilha através do Google Drive

Como alternativa ao processo anterior, é possível partilhar o link para um ficheiro ZIP com o projeto e importar no QField.

Antes de tudo, deve-se ter em atenção o seguinte:

A compactação para ZIP deve ser os ficheiros criados com a exportação e não a pasta de exportação offline

Após o carregamento do ZIP para o Google Drive, é necessário partilhar o ficheiro

O link a utilizar no QField, é o de download e não o de partilha

Algo do tipo https://drive.google.com/uc?export=download&id=1J19RCAGsVSRrcEN0YNkq6j-emWmSApwW, onde 

1J19RCAGsVSRrcEN0YNkq6j-emWmSApwW é o ficheiro partilhado

No QField depois, basta:

1 - Escolher a opção Open local file 

2 - Clicar no botão  e escolher Import URL

3 - Colar o endereço para o ficheiro ZIP na janela de importação e clicar em OK

4 - Após importação, a pasta criada encontra-se dentro da opção Imported Projects 

5 - O projeto está pronto para ser usado em campo

Info

• 

• 

• 
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Para mais informação acerca deste assunto, consulte o endereço https://docs.qfield.org/get-started/storage/.

5.2 Sincronização

5.2.1 QField Cloud

Após a recolha de dados com o QField, pode-se notar na barra de ferramentas que existem elementos adicionados, os quais

precisam de ser sincronizados com a plataforma QFieldCloud. 

Assim, basta clicar no respetivo botão e depois escolher a opção desejada.

5.2.2 PC

Se o processo usado para transferência de ficheiros não foi a plataforma QFieldCloud, estão é necessário transferir a informação

novamente para o PC. Para isso, basta copiar a pasta do projeto offline novamente para o PC e depois:

Info
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1 - Aceder ao menu Plugins > QFieldSync > Syncronize from QField

2 - Definir a pasta com os dados do trabalho de campo e clicar em Syncronize

3 - Por fim, deve-se verificar o layer ao nível de geometrias e tabela de atributos

Como alternativa à utilização do cabo USB, no QField, é possível exportar o projeto ou um conjunto de dados específico para uma

pasta ou comprimir e enviar por diferentes aplicações móveis como por exemplo, e-mail (anexo), OneDrive, Google Drive,

Telegram, Teams, WhatApp.

5.2.2 PC
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6. Antenas GNSS Externas

No que toca ao posicionamento por satélite, vulgo GNSS, o QField pode fazer uso do dispositivo interno do nosso equipamento,

ou então ligar-se a antenas externas de precisão, utilizando para isso ligação Bluetooth, TCP, UDP ou porta série.

Para mais informação acerca deste assunto, consulte o endereço https://docs.qfield.org/how-to/gnss/.

Algumas antenas proprietárias, necessitam primeiro de ligação através da aplicação do fabricante e depois partilhar essa

informação com o software necessário. 

6.1 Trimble Catalyst DA2

Nas imagens abaixo, mostra-se o uso da aplicação Trimble Mobile Manager para estabelecer a ligação a uma antena de precisão,

neste caso a Catalyst DA2 e depois o seu uso no QField.

1 - Configuração da app Trimble Mobile Manager para ligação à antena Catalyst DA2

2 - Visualização do estado da posição recebida através da antena Catalyst DA2

Info

6. Antenas GNSS Externas
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3 - Após a confirmação para partilha da ligação com outras aplicações, o QField irá utilizar a informação da antena Catalyst DA2

6.1 Trimble Catalyst DA2
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6.2 Equipamentos de precisão

Na tabela abaixo, deixamos referência a alguns equipamentos GNSS de precisão.

Equipamento Link

Emlid Reach RX https://emlid.com/reachrx/

Polaris S100 RTK https://www.polaris-gnss.com/home

Ardusimple https://www.ardusimple.com/professional-sets/

Geode https://junipersys.com/products/geode

TH10 Pro Tablet https://singularxyz.com/TH10Pro.html

LT700H RTK Tablet https://chcnav.com/product-detail/lt700h-rtk-tablet

6.2 Equipamentos de precisão
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7. Notas Finais

7.1 Edição simultânea e sincronização

Ao trabalhar um layer em modo offline, se algum utilizador em escritório efetuar alguma alteração nos dados do nosso projecto

QGIS, essas alterações mantém-se quando sincronizarmos os nossos dados recolhidos em campo.

Um projecto offline pode ser usado por vários dispositivos em campo, no entanto não existe resolução de conflitos, ou seja, se

dois utilizadores atualizarem os mesmos dados, os dados mais recentes irão substituir os anteriores.

7.2 Links de interesse

Documentação QGIS:

Manual online - https://docs.qgis.org/3.28/en/docs/user_manual/working_with_vector/vector_properties.html?

highlight=widget#edit-widgets

Documentação QField:

Guias de configurações - https://docs.qfield.org/how-to/

Plugin QFieldSync - https://docs.qfield.org/get-started/tutorials/get-started-qfs/

QFieldCloud - https://docs.qfield.org/get-started/tutorials/get-started-qfc/

Documentação Mergin Maps:

Guias de configurações - https://merginmaps.com/docs/#get-started

Plugin Mergin - https://merginmaps.com/docs/tutorials/mobile/

MerginMaps Cloud - https://merginmaps.com/docs/tutorials/working-collaboratively/

Happy Field Work 😉

• 

• 

• 

• 

• 

• 

• 
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https://docs.qfield.org/get-started/tutorials/get-started-qfc/
https://merginmaps.com/docs/#get-started
https://merginmaps.com/docs/tutorials/mobile/
https://merginmaps.com/docs/tutorials/working-collaboratively/
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